Page 2 of 2

Re: Ludlum model 3 issues

Posted: Fri May 08, 2020 3:53 am
by Richard Hull
I'm with Rex......."Thanks it works now", is not a fix! What fixed it!!!! We've gone through this posting for a bit now.... What fixed it??? We were left hanging by your response or lack thereof.

Richard Hull

Re: Ludlum model 3 issues

Posted: Fri May 08, 2020 9:02 pm
by Sarmad suseyn
Hi Richard
I think my problem was the variable resistor
It is 64 watt resistor. And when i checked the ohms . It gives zero
Value
I think this was the problem. Check it with a 100ohm resister
It burned my multimeter 1000v .
Cant change it right now because of curfew . Every electronics shop is closed. But im sure this is the problem
Thanks Richard

Re: Ludlum model 3 issues

Posted: Sat May 09, 2020 3:36 am
by Rex Allers
Sarmad,
None of that explanation makes any sense to me. There's no 64W pot in a Ludlum 3. The batteries probably couldn't supply 64W if they were shorted. The little pot for HV adjust setting is probably 100K ohm. In the circuit it should draw microamps and micro watts.

Not sure how you were measuring resistance but 0 ohms (a short) seems very unlikely. I can't think of how a single 100 ohm resistor could be used in your diagnosis. I also can't imagine what in a Ludlum 3 could burn your meter.

Of the schematics I have found, the Model 3A looks probably closest to being similar to the pictures you have provided. Not the same but I would guess the circuits are very similar. I edited those schematics to make one page with the HV supply circuit and the HV adj pot as it would connect. I also added a purple dot in the same place where I put one in an earlier version of your picture that I posted. If you can't understand that circuit, you are probably not in a good position to diagnose your device.

HV-circuit.png