Search found 11 matches

by dario_tortato
Wed Mar 22, 2017 11:10 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Adjusting HV on Ludlum 12
Replies: 6
Views: 2274

Re: Adjusting HV on Ludlum 12

Hi, if you have need of the M12 Ludlum manuals, they are present in the forum where I am moderator: http://www.radioactivityforum.it/forum/ ... f=25&t=197
I hope this can be of help.

Dario
by dario_tortato
Thu Mar 16, 2017 10:30 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

After the work of arrangement, some aesthetic restoration:
IMG_3600.JPG
Dario
by dario_tortato
Mon Feb 27, 2017 10:17 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Possible replacement for my now partly failed ST-360 Counter
Replies: 11
Views: 3335

Re: Possible replacement for my now partly failed ST-360 Cou

I insert the manual with schematic if you can serve:
ST360_Operations_Manual.pdf
(726.22 KiB) Downloaded 266 times
Dario
by dario_tortato
Thu Feb 16, 2017 8:57 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

Hi, I did a little test of the instrument, it seems okay.
I put the picture of a pair of spectrum.
IMG_3562.JPG
IMG_3564.JPG
Dario
by dario_tortato
Tue Feb 14, 2017 9:27 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

Tank you, no problem, I've many sample source for test. This isn't my first MCA :-)
I hope the weekend to do some testing and then post the results.

Dario
by dario_tortato
Sun Feb 12, 2017 8:37 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

Tanks. Yes, I've this:
IMG_2520.JPG
IMG_3287.JPG
IMG_3478.JPG
Dario
by dario_tortato
Sun Feb 12, 2017 3:54 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

Ok, I solved the problem, I'm just stupid. To give the supply voltage in the safety, at the instrument under test, I use a 230/230 isolation transformer and a variac with which the straight edge voltage, starting from a hundred volts, and if there are no problems the increased up to the operating vo...
by dario_tortato
Sun Feb 12, 2017 10:54 am
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

This is the link for video: https://www.youtube.com/watch?v=QFi9G9N ... e=youtu.be
the quality is bad, but you see the problem.
I also tried to cool the various components to see if the problem is due to something that works badly or has problems, but nothing changes.

Dario
by dario_tortato
Sat Feb 11, 2017 2:21 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

Further work: I replaced a pair of trimmers and some capacitors. Now the image is in place, however, there is another problem .... the image, as time goes by, begins to have a flicker (especially visible in character, a kind of ripple) which becomes more and more visible. IMG_3557.JPG IMG_3558.JPG I...
by dario_tortato
Sat Feb 04, 2017 2:56 pm
Forum: Neutrons, Radiation, and Detection (& FAQs)
Topic: Problem with Canberra Series 30
Replies: 26
Views: 9199

Re: Problem with Canberra Series 30

Hi Richard, Update: on my unit, power supply ok but no video. I checked and there is a problem in the transistor that drives the high voltage transformer (Q414). I tried to replace it with another PNP that I had (MJ2955). Now picture appears but not sharp and not fill the screen. Of the transistor, ...