Search found 7 matches

by Filippo_Passeri
Mon Mar 19, 2018 10:30 am
Forum: Vacuum Technology (& FAQs)
Topic: Welch 1400 flushing run
Replies: 3
Views: 1593

Re: Welch 1400 flushing run

It’s also possible, that the connection between the thermocouple and the pump inlet is not 100% tight, since the connection is not permanent, it has been sealed with teflon tape. I know it is not the best sealant, but its better than nothing. After the pump was turned of, the pressure rose drastical...
by Filippo_Passeri
Sat Mar 17, 2018 4:13 pm
Forum: Vacuum Technology (& FAQs)
Topic: Welch 1400 flushing run
Replies: 3
Views: 1593

Welch 1400 flushing run

Hello, all. Today I finally acquired motor pulley for my Welch 1400 pump. The pulley was 3D printed since I could not find a replacement online. After it was put together, it's inlet was capped off and the pump was turned on for 45 minutes. Then the dirty, but metal particle free, oil was drained fr...
by Filippo_Passeri
Thu Oct 26, 2017 8:05 pm
Forum: Images du Jour
Topic: Old Welch 1400 reassembly
Replies: 2
Views: 1252

Old Welch 1400 reassembly

Hello, all. Recently I have been accumulating parts for my Welch (probably 1400) head to rebuild it. I have everything except the smaller pulley for the motor. I'm planning to lathe the previous pulley to a smaller diameter to fit the RPM rating of the pump. The motor rating is 500W and 1430 RPM (al...
by Filippo_Passeri
Wed Aug 23, 2017 5:05 pm
Forum: Images du Jour
Topic: 2nd demo fusor run
Replies: 2
Views: 1698

2nd demo fusor run

Hello, everyone. This is my second fusor run, and I think it would be good to share the details. The biggest problem is the vacuum. From the plasma, I can estimate that the pressure is around one torr. That is not surprising since I only have an unidentified lent vacuum pump from school. Because of ...
by Filippo_Passeri
Tue Mar 28, 2017 10:02 pm
Forum: Images du Jour
Topic: Demo Fusor First Plasma Test
Replies: 0
Views: 1027

Demo Fusor First Plasma Test

Hello, everyone. This was the first plasma test on my fusor and its first vacuum. The point of this test was to test the insulation on the cathode, and the electrodes in the vacuum, high voltage environment. The test was brief, but it had revealed some elemental design flaws. Such as, the decision t...
by Filippo_Passeri
Sat Mar 25, 2017 11:48 am
Forum: Images du Jour
Topic: Demo Fusor Voltage and Current Measurment Test
Replies: 4
Views: 1735

Re: Demo Fusor Voltage and Current Measurment Test

Thanks for your input. I have realised I have made a foolish mistake. I mistook gigaohms for megohms, so instead of 33 GΩ resistors, I have 33 MΩ resistors. I have found the appropriate datasheet that states these resistors have a maximum voltage rating of 10 kV. So there is no worry there since the...
by Filippo_Passeri
Fri Mar 24, 2017 10:22 pm
Forum: Images du Jour
Topic: Demo Fusor Voltage and Current Measurment Test
Replies: 4
Views: 1735

Demo Fusor Voltage and Current Measurment Test

Hello, everyone. In the past week, I have made substantial progress on my high voltage metering system. In this test, I used a 33 Gigaohm resistor to serve as a replacement for the outer and inner grid. The high voltage source is a half rectified 9 kV 30 mA NST. For the resistor divider, I used 3x33...